Свежая пресса
Изменения в законе «О бухгалтерском учете и финансовой отчетности в Украине»

Опубликовано: 2017.11.10

Уважаемые коллеги-бухгалтера! Спешим сообщить Вам, об изменениях в ЗУ «О бухгалтерском учете и финансовой отчетности в Украине», касающихся изменений некоторых положений, и вступит в силу с 01.01.2018, а уже с 01.01.2019 года вступят в силу тот абзац, касающийся предоставления финотчетности.

Подробнее...
Обновление программы EffectorSaver

Опубликовано: 2017.10.20

Уважаемые пользователи! Спешим сообщить вам о выходе новой версии программы Effector Saver! 

Подробнее...
Осенняя акция от компании FinSoft

Опубликовано: 2017.10.09

Что еще может так скрасить серые осенние будни, как не акция на программный продукт 1С от компании FinSoft

Подробнее...

Обучающие статьи. Урок 12 - Циклы в 1С

Опубликовано: 2017.01.30

Циклы в 1С

Встречаем новую трудовую неделю очередным выпуском обучающего урока. Сегодня мы рассмотрим, что собой представляют циклы в 1С.

Циклы используются для повторения некоторого числа строк программного кода или для перебора, например, таблицы значений, списка значений или массива.

Циклы бывают нескольких видов. Первый вид «Пока»:

Пока<Какое-то условие>Цикл

//Ваш исполняемый код

КонецЦикла;

Это самая простая конструкция. Условием может быть либо равенство, либо значение булево и т.д.

Например:

Запишем переменную перед началом цикла «Перем1» - она у нас будет выступать в роли ограничителя цикла.

Затем укажем в цикле условие «Перем1 <> 5», т.е. цикл будет выполняться пока наша переменная не примет значение число пять.

После этого (уже в цикле), сообщим значение нашей переменной и увеличим значение переменной на плюс один, перезаписывая переменную.

Листинг 1. Простой цикл Пока:

Листинг кода 1. Пример Цикла

 

У циклов есть несколько основных операторов.

Прервать – прерывает полностью цикл. В указанной строке.

Листинг 2. Простой цикл Пока Прервать:

Листинг кода 2. Пример Цикла с условием

Продолжить – после попадания на эту строчку, платформа вернется в начало цикла. А все что после этой строки не будет выполнено.

Листинг 3. Простой цикл Пока Продолжить:

Листинг кода 3. Пример Цикла с условием Продолжить

 

Следующий тип цикла «Для каждого из»

Для каждого<имя переменной>ИЗ<Имя объекта для перебора>Цикл

//Ваш исполняемый код

КонецЦикла;

Такой цикл хорошо подходит для перебора строк таблицы значений и прочих универсальных коллекций, таких как массив или список значений. Давайте сделаем пример. Создадим таблицу значений, заполним ее несколькими строками и колонками и сообщим результат.

Листинг 4. Простой цикл Для каждого:

Листинг кода 4. Пример Цикла с условием перебора ТЗ

При таком цикле, переменная «Стр» записала в себя значение «СтрокаТаблицыЗначений». В этой переменной, через точку, можно обратиться к колонкам и их значениям.

Следующий тип цикла «Для По» похож на предыдущий цикл. Имеет такую конструкцию:

Для <имя переменной> = <Выражение 1>ПО<Выражение 2>Цикл

//Ваш исполняемый код

КонецЦикла;

Такой цикл менее распространён и служит для выполнения цикла по определенному количеству подходов, указанных в<Выражение 2>. Сделаем пример.

Листинг 26. Простой цикл Для По:

Листинг кода 5. Пример Цикла с условием ПО

Нюанс этого цикла заключается в переменной «Перем1», которую мы определяем и задаем ей значение в первой части конструкции цикла. «Перем1» в начале цикла равна единице, но с каждой итерацией (прохождение полного цикла) эта переменная будет расти на плюс один автоматически. Если вернутся, к примеру цикла «Пока», то там мы самостоятельно записывали переменную, тут же цикл делает это автоматически.

Так же, наша компания проводит обучение по двум курсам:

 Обучение проводится в вечернее время, что позволит вам не отрываться от работы или обучения, практикующим программистом нашей компании.

 От вас требуются уверенные знания ПК, и желание научиться чему-то новому.